Back
Downtime

Kitsu Down

Started 6 May at 10:50pm GMT+7, resolved 6 May at 11:02pm GMT+7.

Resolved

The services are now back online!
Thanks for your patience!

Posted 6 May at 11:02pm GMT+7.
Updated

I have identified the root cause of the issue. It will be resolved within 10-15 minutes. Thanks for your patience!

Posted 6 May at 10:57pm GMT+7.
Created

Kitsu is down, now investigating.

Posted 6 May at 10:50pm GMT+7.