Back
Maintenance

Kitsu is taking a break.

Completed 12 Dec at 10:00am GMT+7.

Updated

Kitsu is now back online!
Welcome to Monday!

Posted 12 Dec at 10:03am GMT+7.
Completed

Maintenance completed

Posted 12 Dec at 10:00am GMT+7.
Updated

Good Night!
Enjoy this music while I'm sleeping: https://youtu.be/KMvUdCyIVxw

Posted 10 Dec at 10:02pm GMT+7.
Started

Server will be taking a break for a day!
So rest while you can and prepare for Monday.

Posted 10 Dec at 10:00pm GMT+7.